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  UC-win/Road/InRoads Data exchange plugin 
 

1. Data exchange (InRoads  UC-win/Road) 
Import InRoads data into UC-win/Road. 

① Select [Tools] -> [Import InRoads] in UC-win/Road. 

② Select file from [Add file] . 

＊As the surface, alignment, cross section files are created separately InRoads, select all required files. 

[surface.xml], [alignment.xml], [cross section.xml] 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

③ Select [Options] button. 

 

 

InRoads Options 

 

 

 

 

 

 

 

 

 

 

 

 

 

InRoads  UC-win/Road 
・Smart Transitions 

I ｆ  It is checked, the different section number between sections is 
corrected to create the transitions. 

・Default length for transitions 
Input the default distance between sections in meter. 

・Max number of structures in a section 
Specify the parts to be included in the cross section. The positive value 
means to include the parts from inside to the cross section and negative 
value means to delete the parts from outside in the cross section. 

・Default length of intersections legs 
Input the intersection size of imported road in meter. 
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Section options 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

[Carriageway marking] tab 
・Carriageway border 

Width：Input the carriageway border width in cm. 
Texture：Select the texture. 

・Lane gap 
Width：Input the lane gap width in cm. 
Texture：Select the texture. 

[Cutting/Banking] tab 
Angle ： Input the angle of the 
banking(cutting/banking）. 
Colour：Select the slope surface colour if there is 
no appropriate texture. 
Texture：Select the texture. 
Texture scale： 

Input the side length of texture in m. 
Berm height：Input the berm height in m. 
Berm width：Input the berm width in m. 
Colour ： Select the berm colour if there is no 
appropriate texture. 
Texture：Select the texture. 

Section surface attributes 
 
・Section surface attributes data 
The cross-sections attributes data can be selected in [Cross-sections 
attributes management]. 
・Associate the name displayed in "Section attribution" with the cross 
section template name of InRoads to setup the texture 

・Cross section attributes data list 
The registered cross section attributes data are listed. 

・[Add record] button  
Add the cross section attributes data. 

・[Copy record] button  
Copy the selected cross section attributes data. 
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④Click [Import as new]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

③The element to be imported can be selected in [Element selection] window. 
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２. Editing in UC-win/Road 
2.1 Creation of intersection 

①Create the road to be crossed with the imported road. 

Click "Edit" →the icon      "Edit layout in plan view" to open “Plan view” dialog. 

 

    ②Create road which crosses the existing road. Click “Make road “icon  in “Plan view” dialog. 

 

 

③Left-click to add the point, and right-click to finish defining the road. 

 

 

 

 

 

 

 

 

 

 

 

*After finishing the definition of road, the road is created by clicking [OK]. When the intersection is not 

created normally, the red mesh is displayed. Click  button to display the Intersection 

troubleshooter. 
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④Adjust the elevation of the 2 roads. 

Right-click the created road, and select “Edit”→”Editing road “Road2”. 

 

 

 

 

 

 

 

 

 

 

 

 

 

⑤Right -click the road vertical curve to select “Add turning point”. The turning point is added. 

 

 

 

 

 

 

 

 

 

 

 

⑥Move the turning point to adjust the elevation to other road (blue line), and click “OK.” 
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⑦The intersection is created. 
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2.2 Editing of intersection 

(1) Editing of intersection 

①Right click the intersection and click “Edit”→”Intersection” 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

②”Intersection Editor” dialog appears. 
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(2)Tab functions in “Intersection Editor” window 

①Leg length/Roundabout 
-Change intersection size 

Input the value in the “Leg length”, and select leg length to change it. 

 
 
-Create roundabout 

 

 

 

１.Check “Roundabout”. Island is placed in the center of geometry as default, and it can be changed to 

roundabout intersection. 

Input the value in “Island radius” “Road radius” “Driving route radius” to edit each radius. The length is 
supposed to be ”Island ＜ Road ≦ Driving route ≦ Ground”. 

 

２.Check “Flare” to set up more smooth contours for large intersection 

 

 
 

 

 

１ 

２ 
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②Road texture tab 
Set up the texture of intersection. 

  

 

1. Import・・・・・・・・・・・・・・・・・・・・・・・・ The saved texture is imported. 

2. Edit texture・・・・・・・・・・・・・・・・・・・・The texture can be edited by the editing function of intersection texture. 

3. Rotate texture：・・・・・・・・・・・・・・・・The texture is rotated. 

4. Output texture（image resolution）・・The resolution for saving the texture is specified. 

5. Output texture（Save）・・・・・・・・・・・The texture is saved. 

 

 

 

 

 

 

 

 

 

 

▲1. Import                            ▲2. Edit texture 

 

 

 

 

 

 

 

 

Rotate texture 

 

 

1 

 

 

 

 

2 
3 
4 
5 
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③Pavement side and banking texture tab 

Click  button and display/edit the texture of road, pavement, and banking. 
 

 

(3) Change of the road intersection size 

Right click road intersection on “Plan View”, and select “Edit”→”Intersection Size” to change the size of 
intersection in “Intersection size” dialog. 
“Intersection Size” can be input between 6-250m in by 1m. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

-Memo- 

Texture of roundabout intersection 

Texture cannot be pasted to island in roundabout intersection. 

Therefore, specify texture on the model after outputting 

to 3DS model. 
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2.3 Arrangement of 3D model (Fake light/New building) 

Arrange the 3D model such as fake light and new buildings around the created intersection.  

There are two methods for arranging the model: Arrange in the arbitrary position, Arranging along the road. 
(1) Arrange 3D model at any point. 

①Click “Edit”→”Place model” . 

②”Place model” dialog is displayed, and select the 3D model to be placed, and then click the position 

where you arrange it on screen. 

 

 

③ 3D model is placed. 

 

 

 

 

 

 

 

 

 

 

 

 

(2) Arrange 3D model along the road. 

 

①When you arrange 3D model from “Edit”→”Arrange 

model” 、click the road with [Ctrl]＋[Shift]＋[Alt] to place it. 
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(3) Change the size and the position on 3D window 

① Click model to be edited. 

 
② Change the size and position in model editing window. 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 

：Move to north, south, east and west by 1m. 
＜Click model and hold Ctrl and drag it.＞ 
 

 ：Single Rotate 
＜Click model and hold Shift＋Ctrl key and drag it＞ 

 

： Enlarge/Reduce the scale 

：Move up/down 
＜Click model and hold Ａｌｔ key and drag it＞ 
 

：Fix position 
 

※＜＞shows the method for moving the model by dragging in 
main window. 
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2.4 Arrangement of roadside object models 

①Select [Edit]→[Roadside Objects] . 

② Select the model to be used and click New. 

 

 
 ③Set up each items. 

 
 

 
 
 
 
 
 
 
 
 
 

 
 
 
 

◆Model tab 
Select road name to be placed. 

Distance・・・distance from road start point. 

Offset・・・distance from road edge. 

Rotate・・・・・Facing X direction of model with driving  

direction is 0 degree. Anticlockwise means the positive. 

Offset （ Vertical ） ・ ・ ・ Specify the height from road 

surface. 

        

◆Group tab 
Number・・・The number of signs to be placed 
Start position・・・Start position of the first sign 
Spacing・・・Space to be placed 
It is placed in the equal interval. If you want to 

change the position separately, go back to main 
screen and enter the position separately. 
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2.5 Setting of traffic flow 
We will try to generate the traffic and register the vehicle type. 

1. Click [Edit]→[Edit traffic flow] . 

2. [Register traffic flow] dialog appears and check the alignment where the traffic flow is generated. 

 

 

3. When [Edit] button on upper right of [Register traffic flow] dialog is clicked, [Edit traffic flow] dialog 

appears to set up the detail of traffic flow. In case of intersection, the traffic flow within the intersection 

can be represented by setting of intersection edit. 

 

 

4. When [Profile…] button in [Register traffic flow] dialog is clicked, 

[Register traffic flow profile] dialog appears. Click [New] to set up the 

details of profile (Mix rate for each vehicle type). 

When the setting complete, click [OK]. 

 

 

Default speed：Default speed can be set in the numerical value. 
Valid：The traffic flow is available when it is checked. 
Time：The time of traffic amount can be set in numerical value. 
Lane：The lane can be selected. 
Traffic amount：The traffic amount can be set in numerical value. 
Profile：Profile(Mix rate for each vehicle type) can be selected. 
 

Traffic Profile Editor 
Name：Input the name of traffic profile. 
Model：Select the model to be used in traffic flow. 
      Register the model to be used in “Load 

models”. 
Proportion：Input the proportion to create the model. 
“Add” button：Add the setting of model. 
“Delete” button：Delete the setting model. 
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5. Bring together the driving vehicle in each group, and control the traffic flow by this unit. 

Display the registration window by "Edit" →"Edit Vehicle Group" to add/delete vehicle group, and edit 

operational profile.  
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2.6 Driving simulation 

Click [View] → [Drive]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Set up the road, direction, speed, lane, and eye height, and confirm them to start driving. 
It may take time until the driving starts depending on the model position. 
In the ramp fork point, driving the ramp and switching into other road can be performed. 
 Check “Ignore Waypoints” to continue driving in the waypoints. 

Push 「↑」,「↓」 key with keyboard while driving to adjust the speed. Push 「←」,「→」 
key to change the driving lane. 

Pause/Continue Driving 

Start driving/Restart 

Change eye point 
[↑]Key ： 5km/hr Increases the speed 
[↓]Key ： 5km/hr Reduces the speed 
[←]Key ： Moves to left lane 
[→]Key ： Moves to right lane 
[Ctrl]＋[↑]Key ： Up the eye point by 10cm 
[Ctrl]＋[↓]Key ： Down the eye point by 10cm 
 
Use numerical keypad while driving to change the eye view by 45° in 360°. 
 
Hold [Alt] and click the road to display “Road information” window, and see the 
information including road name and the position you clicked. 
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3. Utilization of UC-win/Road functions 
3.1 Arrangement of fire 
Next, we will try to arrange the fire on road. 

 

 

1. Click  [Visual Options]. 

2. [Visual Options] dialog appears and check on the check box of Fire and smokes in the Display tab. 

 

3. Click  [Add details]. 

 

4. Select fire tab, and choose “Fire” and the position where you want to place it in the screen. 
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3.2 Arrangement of smoke 
Next, we will arrange the smoke on the road. 

 

①� Click  “Place model”. 

 

②Select fire tab and choose “Smoke" and arrange it by clicking where you want to place. 
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3.3 Time Setting 
Change the time data to set up day time or night time. 

1. Click “Environment character” . 

2. Click “Visual Options” . 

 

3. Click “Sun and moon” tab. 

 

 

④Turn on the check box “The sun and moon positions are determined by the following date and time” and 

change the time to 22:00. 
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3.4 Setting of street light 
Next, we will place the street light on the street. 

1. Firstly, set up the street light. 

Click “Place model” as “1. Fire arrangement”. 

Select “Street light” from the lowest in “3D model tab”. 

 

 

 

 

 

 

 

2. Click any position where you want to place on the screen. 

3. Set up the light source of street light. 

 

Click  “Street light”. 

（Alternatively, click “Edit” -> “Advanced Lighting” -> “Edit Street light”） 
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4. The dialog for setting up the street light appears. Click the arbitrary place on the screen and create the 

light source.(If possible, create image of light source) 

 
 

5. Change the time to night time. 

Turn on the check box “The sun and moon positions are determined by the following date and time” and 

change the time to 22:00. 
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3.5 Setting of headlight 

We will try to set up the headlight of own vehicle. 

 

1. Click  “Headlight” icon. 

（Alternatively, click “Edit”→”Advanced lighting”→”Edit 

headlight”） 

 

 

2. Edit the details of headlight. 

 

3. Click  ”Drive on road”. 

4. Currently the driver’s view is set. Click “Enter” key to change it to the front passenger’s view. 

Driving starts. 

Click “Enter” to switch the view of above two positions. 
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4. New functions of UC-win/Road Ver.5 
4.1Point cloud modeling function 
The point cloud modeling plugin of UC-win/Road Ver.5 allows the loading of point cloud data from 3D laser 

scanner into UC-win/Road. It also enables the editing of this data. 

 

 
 

4.1.1 Loading of point cloud data 

 

1. Start UC-win/Road Ver.5 from the icon on desktop. 

 

▲UC-win/Road icon 
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2. Select “Point cloud modeling plugin” from “Tools” menu and click “Load data”. 

 

 

3. ”Load data” dialog appears and click “Select” button on the upper light. 

 
4. ”Open file” dialog appears. Select the point cloud data “sibuya-007.asc” from desktop and click “Open”. 
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5. ”Load data” dialog appears. Turn on the check box of “sibuya-007.asc”. Click “Read” button on the 

“Load data” dialog. Check it “Comma(,)” is selected for Separator char and “Period(.) for Decimal point 

char. 

 

6. The coordinate is displayed on the left of “Read” button in the center of “Load data” dialog. 

Click “Read” on the upper right of dialog. 
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7. ”Terrain creation option” dialog appears. Turn on the check box of “Scanned in Japan.”, “Load Japan 

Digital Map 50m grid Mesh(Elevation) data” and click “Next”. 

 

 

8. Point cloud data is read. 

 

 

4.1.2 Editing of point cloud data 

Next, we will try to edit the imported point cloud data. 
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4.1.2.1. Data reading 

Firstly, read the other point cloud data. 

1. Select “Tools” from window pull down menu and choose “Point clouds modeling plugin”. 

Select “Load data”. 

 

 

 

2. ”Load data” dialog appears as “4.1.1.(5)” and the other point cloud data can be read. 
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4.1.2.2. Moving of point cloud 

1. Select “Tools” from pull down menu of window and choose “Point clouds modeling plugin”. 

Select “Move data”. 

 

(2) ”Move point cloud” dialog appears. 

 

1. Point cloud data 

Select the point cloud data name. 

2. Move（North, south, east and west, rotation, up and down） 

Move within the point cloud data including rotation. 

3. Move（Enlarge, Reduce） 

Scale the point cloud data. 

4. Variant 

Change the variant parameter of each point in the point cloud data. 

5. Rotate axis 

Change the rotate axis. (x, y, z axis) 

6. Position reset 

Reset the position. 

3 

2 
4 

5 

6 

1 
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4.1.2.3. Checking of the number of point clouds 

1. Select “Tools” from pull down menu of window and choose “Point clouds modeling plugin”. 

Select “Information”. 

 

 

2. Information dialog appears. The number of point clouds can be checked. 

 
 

4.1.2.4 Inverting of point cloud data by height 

1. Select “Tools” from pull down menu of window and choose “Point clouds modeling plugin”. 

Select “Utility”. 

 

 

2. ”Utility” dialog appears. Click “Run” to reverse the point cloud data by height. 

 

② ③ ④ ⑤ ⑥ ①  
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4.1.2.5 Point clouds display option 

1. Select “Options” from window pull down menu. 

 

 

 

2. ”Point clouds display option” dialog appears.Set up the details of point clouds. 

 

 

 

① Point attenuation parameters 

Change the point attenuation parameters. 

② Point cloud 

Change the size of point clouds. 

③ Visible 

Set up the visibility of point clouds. 

 

 

 3 
2 

1 
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4.2 SaaS functions 
 

 
 

 

The SaaS function (sold separately) can be utilized in UC-win/Road Ver.5. This function uses the general 

SaaS system. The remote control can be performed from the client’s side by using UC-win/Road. 

UC-win/Road for SaaS uses Adobe Flash Player which is generally used as a client engine. This is not only 

the video streaming service but the interactive real-time VR system. 
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4.2.1 Setting of SaaS connection 
 

1. Access to the address. 

Type the address of UC-win/Road for SaaS (http://roadforsaas.forum8.co.jp:20000/). 

 

2. Enter the password. 

When you access to the address of UC-win/Road for SaaS (http://roadforsaas.forum8.co.jp:20000/), 

the following dialog appears. Enter the password. 

The password for this seminar is “ ”. 

 
 

 

3. Display of UC-win/Road for SaaS 

When you enter the password, the following screen appears. 

This is the basic screen of UC-win/Road for SaaS. 
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4. Checking of authority 

UC-win/Road for SaaS can be controlled by only one person. Other users are only allowed to view the 

screen. 

When you connect to UC-win/Road for SaaS, you have not received the authority for control. 

 To operate it by yourself, you need to obtain the authority for it. 

You can check on the top of screen if you have the authority for it. 

 

 

 

（5） Acquisition of authority 

When nobody acquires the authority, you can obtain it by clicking “Obtain authority” to operate it. 
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When you acquire the authority, the authority is displayed on the top of screen. The authority can last 60 

seconds and the rest of time is displayed in the bracket. 
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4.2.2 User interface of UC-win/Road for SaaS 
The following image shows the user interface of SaaS screen. 

 

 
 

(1)Top of window 

 

① “Location” tab 
When you have the authority, various geographical names registered into data are displayed by clicking 

“▼” button on the right side of “Jump to”. 

② “Driving” tab 
Start, pause / re-start, and stop the driving and flying. 

③ “Script” tab 
Execute, pause / re-start and stop the script. 

④ “Environment” tab 
Change the time (day time and night time) and the weather. 

⑤ “Zoom” tab 
Change the scale of data. 

⑥ “Synchronize” tab 
Synchronize the data by manually or automatically. 

–    

      

② ③ ④ ⑤ ⑥ 

⑦ ⑧ ⑨ ⑩ 

②  
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(2) Bottom of window 

When you have the authority, hover the mouse cursor over the arbitrary position at the bottom of screen, 

these menus are displayed. 

 

⑦ Orientation 
Change the view point of data in north, south, east, and west. 

⑧ View (up / down) 
Change the view point of data in up and down. 

⑨ Zoom 
Change the scale of data. 

⑩ Up / down / right / left 
Change the view point in up/down/right/left. 
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4.2.3 SaaS operation 

Next, we will try to drive on road. 

 

 

 

4.2.3.1 Selection of driving area 
Select the driving area from the registered data. 

Check if you have obtained the authority (2-2-1) and click “▼” on the right of “jump”, the bottom of 

“Location” tab in the top left of screen to display the location registered on the data. 

Select the driving location from the pull down menu. 
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4.2.3.2 Selection of driving method 
Running can be performed either driving or flying. 

 

4.2.3.3 Driving 
(1) Click “Driving” on far left in the driving tab. 

 

 
 

(2) ”Drive on road” dialog appears. Set up the details including driving speed and click “Confirm”. 
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【Setting of road driving window】 

 

Road name：Road name included in the data is displayed. 

Direction："Start->End”, “End->Start”, “Repeat of Start->End, End->Start” can be selected. 

Speed(km/h)：Click “▲” “▼” to change the speed by 1km/h. 

Lane：Click “▲” “▼” to change the number of lane. 

Position from the start (m)：Click “▲” “▼” to change the position from the start by 1m. 

Height (m)：Click “▲” “▼” to change the height by 0.2m. 

Control point：”Use control point”, “Ignore control point” can be selected. 

 

 

 

 

 

(3) Set up the road. 
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4.2.3.4 Flying 
Next, we will fly the registered path. 

 

 
 

 

(1) Click “Fly flight path” on the driving tab. 
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(2) ”Fly flight path” dialog appears. Set up the details and click “Confirm”. 

 

 
 

(3) Fly the flight path. 
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4.2.3.5 Running of script 
Run the script programmed on data. 

 

 

 

(1) Click ”Run script” on the far left of script tab. 
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(2) ”Run script” dialog appears. Set up the details and click “Confirm”. 

 

 

 

 

(3) The script runs. 
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３、Export UC-win/Road to InRoads 
Export the file edited in UC-win/Road to InRoads.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click [Options] button to set up the data exchange between Road data and InRoads data.関して設定します。 

 

 

①Select [Tools] -> [Export InRoads].Select the road to be exported. 

Choose all roads. Click [OK]. 

UC-win/Road  InRoads 
・Export terrain data 

If it is checked, the terrain data is exported otherwise, it’s not 
exported. 

・Margin for terrain export 
Input the distance between the defined range and the range 
actually to be generated in meter.  
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